5 Replies · Latest reply on Oct 17, 2017 5:30 AM by Vijay Talupula

    Service Now Reports

      I am trying to create a few reports in service now. Some of reports have to be presented in bar graphs.

       

      I am using "Assigned Portfolio" as the group by field to create the bar graph reports. "Assigned Portfolio" field contains values like

      Digital Portfolio, Banking Portfolio, IT Portfolio etc.

       

      After applying group by, each bar in the bar graph should display these actual values of the "Assigned Portfolio"

      (for example: Digital Portfolio, Banking Portfolio etc.) but instead the bars currently display the sys_id of the portfolio field.

       

      What could possibly be the matter. This happens only when I group by "Assigned Portfolio" and not when I group by other fields

      like Stage etc. Any help is much appreciated !!

        • Re: Service Now Reports
          Darius Koohmarey

          Can you confirm that the table that assigned portfolio references has a field like name that is currently set to display=true in the dictionary?

          Reference Variable showing sysid instead of values

          If the reply was informational, please like, mark as helpful or mark as correct!

            • Re: Service Now Reports
              Akash Mahajan

              Thank you for your response Darius ! I greatly appreciate it.

               

              I have added a snapshot of the table and fields below. Kindly take a look.

               

              Screen Shot 2017-10-12 at 10.59.09 PM.png

               

              If you notice, the "Display" field is set to false for "Assigned Portfolio". But it is the same with all the custom variables we have created, so I am confused that why the other custom variables for example "Assigned Tech Fellow" which have the same set of configuration are displayed properly as labels in the reports. And why is it only with the "Assigned Portfolio" variable values being displayed as sys_id in reports.

               

              Just to mention, if in case I have to change the "Display" value to "true" for "Assigned Portfolio" variable, I would not be able to do so as I have limited access as per my role in the system. Again ! All these variables are created by developer team in the same way, then why Assigned Portfolio gives a problem.

               

              Any help is sincerely appreciated !

                • Re: Service Now Reports
                  Vijay Talupula

                  Hi Akash,

                   

                  If possible, could you share the report screenshot with condition builder?

                  1 of 1 people found this helpful

                  Regards,
                  Vjay
                  ServiceNow Developer

                    • Re: Service Now Reports
                      Akash Mahajan

                      Hi Vijay !

                       

                      Here are some more screenshots.

                       

                      First: This is a List report. The "Assigned Portfolio" variable and values get displayed properly only in the List report.

                      Screen Shot 2017-10-13 at 10.12.06 AM.png

                       

                       

                      Second: This is a Bar Graph report. The "Assigned Portfolio" variable and values do not get displayed properly. This happens when I use any graphical report other than List report.

                       

                      BBB.png

                       

                       

                      Third: This is a Multilevel Pivot Chart report. The "Assigned Portfolio" variable and values do not get displayed properly. Again, this happens when I use any graphical report (except List report). I have added how the variable and values should be displayed in the screenshot.

                       

                      Screen Shot 2017-10-13 at 9.53.35 AM.png

                       

                       

                      All these variables are custom variables (all have the same configuration except Mandatory fields) and these are related to a scoped application.

                       

                      Assigned Portfolio is a Choice Field but there are other custom variables also like "Deliverable" which is a Choice Field but is displayed properly irrespective of the graph.

                       

                      I hope this clarifies the problem we are facing. Thanks !!

                        • Re: Service Now Reports
                          Vijay Talupula

                          Hi Akash,

                           

                          I have tried checking a variable of select box (where values are choices in the drop-down) and don't see any issues. As per my understanding, I think the field "Assigned Portfolio" looks like a custom reference field where you are getting values from a table. if so, can you please share the table form once if possible.

                           

                          I may need some more details,

                           

                          1) How the values are coming to this field over a form - Dictionary entry.

                          2) Form for an existing record entry.

                          Regards,
                          Vjay
                          ServiceNow Developer